BSS Sites - Azure US region - Performance Degradation

Minor incident BSS Sites Azure US region
2025-10-23 16:10 EEST · 10 minutes

Updates

Resolved

The issue that caused performance degradation in platform’s BSS application has been resolved. Affected sites and services are operating normally.

October 23, 2025 · 16:20 EEST
Investigating

We are currently investigating an issue which impacts platform’s BSS application performance. Some users may experience slower response times than usual.

October 23, 2025 · 16:10 EEST

← Back