GR Region - Temporary Service Interruption
Major incident
BSS Sites
GR region
Storefront Sites
GR region
2025-10-28 12:19 EET
· 1 hour, 12 minutes
Updates
Update
October 28, 2025 · 13:48 EET
Our engineers have performed the necessary mitigations to resolve the connectivity issues and our services are operating normally. Users should be able to connect to all BSS and Storefront sites
Update
October 28, 2025 · 12:46 EET
We have identified the cause of the problem and our engineers are actively working to resolve it and restore service operation.
Issue
October 28, 2025 · 12:28 EET
We are experiencing connection issues with our platform sites in the GR region. Customers may be unable to login to the Storefront sites or manage their services using the BSS back-end application.
← Back
Cloud Platform Status