Notification Engine - Azure EU region - Maintenance from 2023-02-14 01:48 EET to 2023-02-14 02:28 EET

Scheduled maintenance Notification Engine Azure EU region
2023-02-14 01:48 EET · 40 minutes

Updates

Resolved

Notification Engine Azure EU region Maintenance completed

February 14, 2023 · 02:28 EET
Investigating

Notification Engine Azure EU region Maintenance kicked off

February 14, 2023 · 01:48 EET

← Back